!--HQ
username ISP password 0 cisco
username New password 0 cisco
interface GigabitEthernet0/0
ip address 172.16.0.1 255.255.255.128
interface Serial0/0/0
encapsulation frame-relay
frame-relay lmi-type q933a
interface Serial0/0/0.41 point-to-point
ip address 172.16.0.193 255.255.255.252
frame-relay interface-dlci 41
clock rate 2000000
interface Serial0/0/1
ip address 172.16.0.197 255.255.255.252
encapsulation ppp
ppp authentication pap
clock rate 2000000
interface Serial0/1/0
no ip address
encapsulation ppp
ppp authentication chap
ppp pap sent-username HQ password 0 cisco
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
passive-interface GigabitEthernet0/0
network 172.16.0.0 0.0.0.127 area 0
network 172.16.0.192 0.0.0.3 area 0
network 172.16.0.196 0.0.0.3 area 0
default-information originate
ip route 0.0.0.0 0.0.0.0 Serial0/1/0
!---NewB
username HQ password 0 cisco
interface GigabitEthernet0/0
ip address 172.16.0.129 255.255.255.192
interface Serial0/0/0
description Link to NewB
ip address 172.16.0.198 255.255.255.252
encapsulation ppp
ppp authentication pap
ppp pap sent-username NewB password 0 cisco
clock rate 2000000
interface Serial0/0/1
ip address 172.16.0.198 255.255.255.252
encapsulation ppp
ppp authentication pap
ppp pap sent-username NewB password 0 cisco
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
!--B1
ip dhcp excluded-address 172.17.2.1 172.17.2.10
ip dhcp pool VLAN20
network 172.17.2.0 255.255.255.0
default-router 172.17.2.1
ip name-server 172.16.0.5
spanning-tree mode pvst
interface GigabitEthernet0/0
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 172.17.0.1 255.255.254.0
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 172.17.2.1 255.255.255.0
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 172.17.3.1 255.255.255.128
interface GigabitEthernet0/0.99
encapsulation dot1Q 99 native
ip address 172.17.3.129 255.255.255.192
interface Serial0/0/0
encapsulation frame-relay
frame-relay lmi-type q933a
interface Serial0/0/0.100 point-to-point
ip address 172.16.0.194 255.255.255.252
frame-relay interface-dlci 100
clock rate 2000000
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 172.16.0.192 0.0.0.3 area 0
network 172.17.0.0 0.0.1.255 area 0
network 172.17.2.0 0.0.0.255 area 0
network 172.17.3.0 0.0.0.127 area 0
!--B1-B2
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
ip default-gateway 172.17.3.129